Ne arayalım?

ARAMIZA KATILIN

BİZE ULAŞIN

Adres:

E-posta:

host/bin/bilisimlife.dll

iletisim@bilisimlife.net

Router Konfigürasyonu 1074910749 okunma

02.12.2017

Ağ Sistemleri

Rserit

WAN’lar birbirine bağlanmak için router cihazlarını kullanırlar. Bu router cihazları iki WAN arasındaki iletişim paketlerini yönlendirir. Ancak router’ın bu iki WAN’ı tanıması gerekir. Tabi ki bunu router’a tanıtacak olan bizleriz. Her iki ağın ip adresleri, router’ların adresleri, varsayılan ağ geçitleri vs. gibi bilgileri bilmemiz gerekecektir.

Bu makalemizde temel router konfigürasyon komutlarına değineceğiz. Bu makaleyi aşağıdaki şemayı örnek göstererek anlatacağım.



Yukarıdaki şemada üzerinde çalışacağımız ağı görmektesiniz. Bu ağı router’lara tanıtalım ve iletişimi sağlayalım.

Temel Router Konfigürasyonu

Temel router konfigürasyonu başlığı altında router cihazlarının basit özelleştirmelerinden bahsedeceğim.

Öncelikle RouterX’e girelim. Komut ekranı bize şunu soracaktır:

--- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]:

Buna no olarak cevap vermeliyiz. Çünkü burada konfigürasyon sihirbazına ihtiyacımız yok. Elle (manuel olarak) konfigüre edeceğiz.



Şu anda user exec modundayız. Router başlayınca bu modda başlar. Bir üst moda yani privileged exec moduna çıkmak için enable komutunu, privileged modunda global configure moduna çıkmak için configure terminal (ya da kısa olarak conf t yazabilirsiniz) komutunu giriyoruz. Bu modların her birinden çıkmak için exit komutunu yazabiliriz.



Daha önceden bu ayarlardan Router Temelleri makalemde bahsetmiştim. Bütün ayarlamaları global konfigürasyon modunda yaparız.

Şimdi… Şekilde gördüğünüz RouterX, router’ın ismi. Ancak bunu şemaya yazı olarak yazdım. Anlayacağınız router ismini şu anda varsayılan olarak Router olarak biliyor. Bizler buna hostname diyoruz.

Hostname ayarını değiştirmek için hostname girilen_isim komutunu bu modda girmemiz gerekecek.

Örnek olarak şöyle:
Router(config)##hostname RouterX
RouterX(config)#




Router’ımızın ismini rahatlıkla değiştirdik. Router’ımıza bağlanacak olan kullanıcılar olabilir. Onlara mesaj da gönderebiliriz. Bunu banner motd komutu ile gerçekleştiriyoruz. Banner motd komutunu yazıp # işaretini yapıp mesajını yapıp, tekrar aynı işaretle mesajı kapatarak bu mümkün.

Örnek:

RouterX(config)#banner motd #BilisimLife.net - Bilisim Teknolojileri#
RouterX(config)#exit



Şimdi Router’da çıkış yapalım ve tekrar bağlanalım, mesajı verecek mi…



Görüldüğü gibi verdi. Bunun haricinde üç tane daha var. Exec banner, Incoming banner ve login banner. Bunları da ayrıca deneyebilirsiniz.

Router’da Şifreleme

Başlangıç  notu: Bu konuyu daha önce Cisco Router'a Şifre Koymak makalesinde bahsetmiştim.

Router’da güvenlik de önemlidir. Router’a şifre koyulabilir. User exec modundan bir üst moda çıkmak, herkesin bağlanıp yapabileceği bir şey. Ancak şifre koyarsak bu iş kısıtlanıyor olacak. Bir router’a iki şekilde şifre koyulabilir.

1. enable password
2. enable secret

Enable password ile yazılan bir şifreyi privileged modunda show running-config komutuyla görebiliriz. Ancak enable secret ile girilen şifre görülmez. Yani şifrelenmiş olarak görülür.

Bu ne demek? Router konfigürasyon dosyanız ele geçirildiğinde enable password ile girilen şifreyi rahatlıkla okuyabilir ancak secret ile girilen bir şifreden bir şey anlamayacağı anlamına geliyor. Enable password neden kullanılıyor peki? IOS versiyonu eskiyse ya da enable secret şifresi yoksa kullanılır.

Bunu deneyelim.

Enable password ve enable secret ile şifre koyalım.

RouterX(config)#enable password Rserit
RouterX(config)#enable secret Rserit
RouterX(config)#


Resim olarak aşağıdaki gibidir.



Şimdi Router’dan çıkalım. Her bir modda exit yazalım.

Tekrar giriş yapalım. User exec moduna düştük. Bir üst moda çıkmak için enable yazalım. Bizden şifre istediğini göreceksiniz. Koyduğunuz şifreyi buraya yazın.



Şifreyi girdikten sonra bir üst moda düştük. Bütün çalışan ayarları görmek için show running-config komutu girilir. Tabi ayarlar içerisinde girdiğimiz şifreler de var. Bu komutu yazalım ve bakalım.

Komutu girdikten sonra bana bütün ayarları gösteriyor. Belki de burada bir şifre vardır :)



Secret ile girilen şifrelenmiş, password ile girilen direkt olarak gösteriliyor. Güvenlik açısından secret ile girilmekte.

Enable secret ile girilen şifrenin derecesini global configuration modunda service password-encryption komutuyla belirleyebilirsiniz. Yani şifreleme de size bırakılmış.

Bizler router’a direk olarak da farklı yollardan da bağlanabiliriz. Tabi ki portlara da şifre koyabiliriz.

Konsol portuna şifre koymak için line console komutunu kullanırız. Örnek kullanımı:

RouterX(config)#line console 0
RouterX(config-line)#login
RouterX(config-line)#password Rserit
RouterX(config-line)#




Konsol bağlantısı kurup deneyelim.





Router’a telnet bağlantıları da olabilir. Bunun için telnet şifresi için line vty komutu girilir. Örnek kullanımı:

RouterX(config)#line vty 0
RouterX(config-line)#login
RouterX(config-line)#password Rserit
RouterX(config-line)#exit
RouterX(config)#


Eğer daha önceden şifre atanmamışsa şöyle bir bilgilendirme alabilirsiniz: % Login disabled on line 66, until 'password' is set.

Bu bir hata değildir, bir tür bilgilendirmedir. Şifre atamanızı istemekte. Zaten biz de onu yapıyorduk.



Aux portu için şifreleme ise şöyledir:

RouterX(config)#line aux 0
RouterX(config-line)#login
RouterX(config-line)#password Rserit
RouterX(config-line)#exit
RouterX(config)#

Mantık aynıdır.

Ancak burada dikkat etmemiz gereken bir nokta var. Farkındaysanız bütün şifreleri aynı koydum. Hepsi Rserit. Bunları farklı da atayabilirdim. Ancak, router’a yapılan her telnet isteğine router cihazı, kullanımda olmayan bir portu atadığından bağlantıyı kuran kişinin tüm bu telnet portlarına atanmış şifreleri bilmesi gerekiyor. Bu yüzden aynı şifreleri atamak daha akılcı bir davranış olacaktır.

Bununla birlikte bir de kullanıcının router’a yaptığı bağlantı sonrasında bir işlem yapmadan ne kadar süre aktif kalacağını da biz belirleyebiliriz. Bunu exec-timeout komutuyla belirleyebiliyoruz. Bu web sitelerde güvenlik için yapılan bir şeydi. Session.Timeout’dan biliriz.

Örnek olarak konsol bağlantısına bunu belirlemeniz gerektiğini düşünelim. Konsol port ayarlamasına girelim.

Örnek kullanımı şöyledir:

Router(config)#line console 0
Router(config-line)#exec-timeout 1000
Router(config-line)#exit
Router(config)#




Router’da Arayüz Bağlantıları

Başlangıç notu: Bu konuyu da Router Temel Arayüzleri makalesinde ele almıştım. Gözatabilirsiniz.

Router’da çeşitli arayüzler vardır. Temel olarak fastethernet ve serial portları ele alınır. Serial portlarıyla router’lar birbirlerine bağlanılır, haliyle onların haberleşmeleri için konfigürasyonu yapılır. Fastethernet üzerinde ise LAN’ları birbirine bağlamak için tanımlamalar yapılır.

Bu konuyu iki konuya ayırarak öyle ele alalım.

1. Serial Arayüz Yapılandırması

Router’lar birbirlerine serial DTE ya da serial DCE uçlu kablolarla birbirlerine bağlanılır. Serial portu üzerinden router’lar birbirleriyle iletişim sağlar.

Not: Packet Tracer üzerinde WIC-2T portu olarak geçer.

Öncelikle iki router’ı ele alalım. Birisi RouterX, diğeri RouterY. Bunları birbirine bağlayalım. Serial DCE kablosuyla bağlanamanızı öneririm. DCE kablosunda clock rate göstergesi bulunr. Clock rate komutuna birazdan değineceğiz.

Router’lar birbirine bağlandıktan sonra (şemadaki gibi) RouterX’in içerisine girelim ve ayarlamalara başlayalım.

Öncelikle, router’ların ip adresleri ne olacak? Genellikle basit olduğundan 10.0.0.1 gibi bir ip adresi atanılır. Bu size kalmış bir tercih. RouterX’e 10.0.0.1, RouterY’ye 10.0.0.2 ip adresini atayalım.

RouterX’i açıp global configuration moduna geçelim. Portumuzun ismi nedir? Baktığımızda Serial 0/2/0 olarak gözüküyor. O halde bu porta ayarlamaları yapacağız. interface serial 0/2/0 komutunu girelim. Sizde port farklı olabilir, sizdekine uygun yazın.
Kısaltma olarak int ser0/2/0 diye de yazabilirim.

Router(config)#int ser0/2/0
Router(config-if)#


Şimdi buraya yazmamız gereken çeşitli bilgiler var. Öncelikle portu açmamız gerekecek. Neden? Konfigüre edilen portun işlevsel olabilmesi için aktif yani up olması gerekir. Varsayılan olarak bütün arayüzler pasiftir. Buna administratively disabled denir.
Bunun için no shutdown diyoruz.



Sıra geldi ip adreslerini yazmaya, bunun için ip address ip_adresi ag_maskesi şeklinde komutumuzu gireceğiz.

Yani şu şekilde:

Router(config-if)#ip address 10.0.0.1 255.255.255.0
Router(config-if)#

Bundan sonra clock rate atamamız gerekecek. Clock rate saat ile alakalıdır. Genellikle 56000 değeri girilir. Yani şu şekilde komut gireceğiz:

Router(config-if)#clock rate 56000

Ardından exit diyerek bu porttan çıkalım.

Aşağıdaki resimde daha net görebilirsiniz.



Şimdi burada uyguladığımız ayarların aynısını RouterY üzerinde de uygulayalım. Ancak burada clock rate ataması olmayacaktır. Clock rate işareti hangi router’ın üzerindeyse o router üzerinde uygulanır.

RouterY ayarlamaları şu şekilde olacaktır:

RouterY(config)#interface serial 0/2/0
RouterY(config-if)#no shutdown

RouterY(config-if)#
%LINK-5-CHANGED: Interface Serial0/2/0, changed state to up

RouterY(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/0, changed state to up

RouterY(config-if)#ip address 10.0.0.2 255.255.255.0
RouterY(config-if)#exit
RouterY(config)#


Aşağıdaki resimden daha iyi anlayabilirsiniz.



Bu kadar! Şu anda serial portunu yapılandırmış olduk. Haberleşip haberleşmediğini görelim.



Görüldüğü gibi başarılı bir şekilde haberleşiyorlar.

2. Fastethernet Arayüz Yapılandırması

Switch’ten router’a aktarılan RJ-45 uçlu kablo türü fastethernet portuna bağlanılır. Ardından router bunu algılar, geriye bir tek yapılandırması kalır. En yukarıdaki şemaya tekrar bakalım.

Şimdi RouterX’e takılmış, 192.168.2.1 ip adresli ağı RouterX’e tanıtalım ve o ağın router cihazıyla haberleşmesini sağlayalım.

Bu ayarlamalar da serial portunu ayarlamak gibi, farksız bir şey yok.

RouterX’te global configuration moduna girelim. Switch’ten gelen kablo hangi porta bağlıysa onun ismi yazılacak. Genellikle bu fastethernet0/0 olur.

Şimdi buraya interface fastethernet0/0 yazıp portun içerisine girelim. Portun içine girdiğimizde no shutdown diyerek portu açalım.

Şöyle:

Router(config)#int fast0/0
Router(config-if)#no shutdown


Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#


Resimde de görebilirsiniz.



Port açıldıktan sonra ip adresi girilmelidir. Ancak IP adresi, router’a bağlanacak ağın varsayılan ağ geçidi olmalıdır. Yani default gateway adresi olmalı. Bu da şekilde de gösterildiği gibi 192.168.2.1 adresidir. Eğer ki bunun haricinde bir ip adresi yazarsak (örneğin 192.168.2.2 adresi), router yalnızca yazılan ip adresiyle iletişime geçecektir. Diğerlerini tanımayacaktır.

Yani şöyle girilmelidir:

Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#exit
Router(config)#


Resim olarak da aşağıda mevcuttur.



Unutmadan! Bu alanda açıklama da ekleyebiliyoruz. Örneğin bu portun açıklamasını yapabiliriz. Bunu description komutu sayesinde yapabiliyoruz.

Örnek bir kullanımı:

Router(config-if)# description Sol Taraftaki LAN



Bu kadar! Şimdi iletişime geçiyor mu kontrol edelim.



Yukarıdaki resimden de görüldüğü gibi, PC2’den RouterX’e atılan bir paket başarıyla iletiliyor. Bu da ayarlamamızın doğru olduğunu gösteriyor.

Aynı ayarlamaları RouterY için de uygulayalım.

Onunkisi şöyle olacaktır:

RouterY(config)#int fast0/0
RouterY(config-if)#no shutdown

RouterY(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

RouterY(config-if)#ip address 193.168.1.1 255.255.255.0
RouterY(config-if)#exit
RouterY(config)#

Aşağıda görüldüğü gibi RouterY ayarları böyledir.



Bunun haricinde RouterX’e uyguladığımız gibi, buraya da bir açıklama yani description ekleyebilirsiniz.

Her Iki LAN’ın Iletişimi

Başlangıç notu: Burada kullanacağımız RIP protokolü hakkında daha önceden Cisco Router'da RIP Yapılandırması isimli makalesinde anlatmıştım. Gözatabilirsiniz.

Şu anda yalnızca router’ların belirli portlarına ayarlamalar yaptık. Esasında her iki LAN’ında birbiriyle haberleşmesini sağlayamadık. Bu ne demek? Sol taraftaki PC’lerden biri sağ taraftaki PC’lerden birine bir paket gönderse, bu başarısız olacak demektir. Çünkü her iki router’ın tanıması gereken ip adresleri var. Örneğin RouterX şu anda yalnızca sol taraftaki LAN’ı tanıyor, sağ taraftakinin ip adresi yazılı olmadığı için nereden tanısın? Burada devreye RIP giriyor.

Bkz: RIP

RIP protokolü, en fazla 16 hub giden bir yönlendirme protokolüdür. RIPv2’de vardır, bunun haricinde OSPF’de vardır ancak en basiti RIP olduğundan buna değiniyorum.

RouterX’e girelim RIP ayarlarını yapalım. Global configuration modunda router rip komutunu yazalım.

Yani şöyle:

RouterX(config)#router rip
RouterX(config-router)#


Config-router denilen alana girdik. Burada çeşitli ağlar tanımlanır. Istediğiniz ağı buraya tanımlayabilirsiniz. Şu anda RouterX’teyiz, tanımlamamız gereken ağ hangisi olacaktır? Tabi ki sağ taraftaki ağ. Yani RouterY’ye bağlı ağ. Bunun için network ip_adresi komutunu gireceğiz.

Örnek kullanımı:

RouterX(config-router)#network 193.168.1.1
RouterX(config-router)#


Bakın ağ maskesi vs. girmedim, çünkü RIP bu konuda pek gelişmemiş bir protokol. RIP v2’de girilmekte.

Not: Yönlendirme protokolleri konusunu daha derin olarak Sabit Yönlendirme ve Yapılandırması, Yönlendirme Protokolleri gibi makalelerimde göz atabilirsiniz.

Şu ana kadar girmiş olduğunuz ip adreslerini teker teker girin. Router’ların ip adresleri, her iki lan’ın ip adresi gibi bilgileri buraya girin.

Yani şöyle:

RouterX(config)#router rip
RouterX(config-router)#network 193.168.1.1
RouterX(config-router)#network 192.168.2.1
RouterX(config-router)#network 10.0.0.0
RouterX(config-router)#exit
RouterX(config)#




Bu ayarların aynısını RouterY’de de uygulayalım.

Şöyle bir uygulaması var:

RouterY(config)#router rip
RouterY(config-router)#network 192.168.2.1
RouterY(config-router)#network 193.168.1.1
RouterY(config-router)#network 10.0.0.0
RouterY(config-router)#




Yanlış bir ip girmiş olmamız da mümkün. Bu yüzden bu alandan bir ip adresi silmek istiyorsak no network ip_adresi komutu girilir.

Şu şekilde:

RouterY(config)#router rip
RouterY(config-router)#no network 10.0.0.0
RouterY(config-router)#no network 192.168.2.0
RouterY(config-router)#no network 193.168.1.0
RouterY(config-router)#exit




Konfigürasyonumuz bitti! Şu anda ayarlamalarımızı bitirdik. Her iki LAN’da birbiriyle iletişimde gözüküyor. Test edelim.



Yukarıdaki resimden de anlaşıldığı gibi, her makine birbiriyle iletişim içerisinde. Şu anda temel olarak router konfigürasyonunu tamamladık. Bu adıma kadar gelebilmişseniz sizleri tebrik ederim.

Router Ayarlarını Kaydetme

Router şu anda bütün bu ayarlarını RAM üzerinde tutuyor, yani router kapatılıp tekrar açılsın, bütün bu işlemler kaybolacak. Bunun için privileged modunda write memory komutu girilir. Böylelikle konfigürasyon dosyamıza ayarlar yazılır.

Router#write memory
Building configuration...
[OK]
Router#


Router Üzerindeki Bazı Show Komutları

Şu anda yaptıklarımızın hepsini privileged modundan show running-config komutuyla görebiliriz. Show komutları bizlere istediklerimizi gösterebilir.

Örnek olarak RouterX’te neler yapmışız bakalım:


Router#show running-config
Building configuration...

Current configuration : 758 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
spanning-tree mode pvst
!
!
!
interface FastEthernet0/0
 description Sol Taraftaki LAN
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/2/0
 ip address 10.0.0.1 255.255.255.0
 clock rate 56000
!
interface Serial0/2/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 network 10.0.0.0
 network 192.168.2.0
 network 193.168.1.0
!
ip classless
!
!
!

line con 0
 exec-timeout 1000 0
line vty 0 4
 login
!
!
!
end
Router#




Bunun haricinde, yönlendirilmiş ip adreslerini de ayrıca görebiliriz. Bunun için show ip route komutunu girmemiz yeterlidir.

Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, Serial0/2/0
C    192.168.2.0/24 is directly connected, FastEthernet0/0
R    193.168.1.0/24 [120/1] via 10.0.0.2, 00:00:00, Serial0/2/0
Router#

Görüldüğü gibi bizlere nelerin bağlı olduğunu vs. gösteriyor. Çeşitli harf atamaları yapılmış, onların da açıklamaları verilmiş zaten. Örneğin C, connected (bağlandı), S, static (statik yönlendirme), R, RIP vb. gibi.




Router Debug Işlemi

Router üzerinde hatalı işlemler yapmış olabiliriz. Bunun için privileged modunda debug komutu girilir. Ancak bu işlem router’ın donanım kaynağını fazlasıyla kullanacaktır. Bu yüzden debug işlemi bittiğinde undebug all ya da no debug all komutu girilir.

Örneğin RIP ip adreslerinde debug işlemini etkin kılmak istiyorum. O halde komut şöyle gerçekleştireceğim:

Router#debug ip rip
RIP protocol debugging is on   


Eğer debug işleminin durmasını istiyorsam şu komutu gireceğim:

Router#no debug all
All possible debugging has been turned off
Router#




Cisco Router IOS Yazılımından Birkaç Ipucu

  • Hangi modda, hangi arayüzde olursanız olun ? işareti ile bütün kullanabileceğiniz komutları görebilirsiniz.
  • Bazı komutları uzun uzun yazmanıza gerek yok, kısaltmış halleri de var. Conf t, int fast gibi.
  • Eğer yeni bir komut denemesi yapıyorsanız konfigüre edilmiş bir router üzerinde denemeyiniz. Farklı bir router üzerinden denemeniz sizin yararınıza olur.

Bahsettiklerim haricinde Router IOS yazılımı içerisinde birçok ayarlamalar vardır. Şu anlık bu kadarına değindim, bunlar bizlerin işini hayli görecektir.

Eğer yapamadığınız nokta olursa forum içerisinde Genel Ağ ve Iletişim kategorisinde başlık açmanızı rica ederim.
Kolay gelsin.

Recep ŞERIT

BİR YORUM YAZIN